Feature request #2673

Enhancements for georeferencer

Added by Marco Hugentobler over 9 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:mmassing -
Category:C++ Plugins
Pull Request or Patch supplied: Resolution:fixed
Easy fix?:No Copied to github as #:12733

Description

This patch adds the following functionality to the georeferencer:
- georef window can be docked / undocked (configure georeferencer dialog)
- gcp items may show ids / coords / ids and coords
- it is possible to print a pdf report after transformation that contains information about the parameters and the residuals
(pdf icon in transformation settings)
- for linear transformation, it is also possible to do warping (e.g. if resolution change is needed )
- it adds the possibility to do helmert transformation with a world file. However, because QGIS is at the moment slow reading rasters with rotated world files, this possibility is disabled for helmert transformation at the moment

Manuel, could you review the patch?

cheers,
Marco

100423_georefpatch.diff Magnifier (50.2 KB) Marco Hugentobler, 2010-04-23 01:33 AM

History

#1 Updated by mmassing - over 9 years ago

Hi Marco,

thanks for the patch, looks great. One question though, is it the intended behaviour that
the pdf report generator uses the current viewport of the georeferencer to show the input image,
instead of e.g. the bounding box of the whole input file?

Also, I'd rename the method "getOriginRotationScale" to "getOriginScaleRotation" to match the function arguments/other classes, if you don't mind :-)

cheers, Manuel

#2 Updated by mmassing - over 9 years ago

Hi,

I have commited part of the patch in a9f345f0 (SVN r13437), except for the dock widget stuff.

The dock widget code unfortunately lead to a crash on plugin exit and screen corruption
upon undocking, so I'm holding back that part until I know what the cause is.
It seems to have occured only after an update to Qt 4.6, so this might be a Qt 4.6
issue.

Manuel

#3 Updated by mmassing - over 9 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

The problem with Qt 4.6 seems to be fixed with f8b728bd (SVN r13501), so I have commited the remainder of your patch, thanks.

Also available in: Atom PDF