Bug report #2643

Problems with New Labelling plugin

Added by mesajs - over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:-
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:12703

Description

New labelling works well on the map canvas, but rendering in print composer is poor:

1.Label placement is too low.

2.Fonts not properly rendered.

Attached examples are snips showing roughly the same section of a map tagged as follows:

AROUND - Labels around points, or above line and below line selected for lines

OVER - Labels over points, or on lines

CANVAS - as appears on the main map canvas

COMPOSER - created in map composer with map saved as a PNG image

For example, in composer_around.jpg, the label Deer fence (lower left hand corner) is on the line, while labels Fence A and Fence B are well below their lines. Points Tl48 and Tl61 (to the left of label Upper wetlands) are so far below their associated points that Tl48 appears to be associated more closely with point Tl61. Label Tl61 looks like T61. The equivalent snippet from the main QGIS screen (canvas_around.jpg) shows none of these deficiencies.

Using QGIS r13288 under Windows Vista 64.
Font is Ms Shell Dlg 2, font size 8. The label engine is set to Show all labels.

PS Sample composer_screen_around_jpg shows how the section from composer_around.jpg appears on the screen before saving as a png image. It's virtually unreadable.

History

#1 Updated by mesajs - over 10 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Also available in: Atom PDF