Bug report #2602

(new) coordinate system selector issues

Added by Giovanni Manghi over 11 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Projection Support
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12662

Description

Tested with qgis trunk in both linux and windows.

a) open the selector, put the focus on the space where you can write the name/auth.id and the click on "cancel", it will warn you that

"No matching projection found."

b) now if you want to search for a epsg code (or other authority code) you can't simply search for (example) "4326" because it will return

"No matching projection found."

you need to enter "epsg:4326" which is not very intuitive considering that searching for names works in a different way -> it finds all the records that match the search string.

I suggest to make the auth.id search work the same as the name search, or at least add a dropdown to select the authority for auth.id searches.

Associated revisions

Revision 0cc1bc78
Added by Jürgen Fischer over 11 years ago

projection search improvements (fixes #2602)

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision 639cba10
Added by Jürgen Fischer over 11 years ago

projection search improvements (fixes #2602)

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Jürgen Fischer over 11 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

fixed in 639cba10 (SVN r13186).

Also available in: Atom PDF