Bug report #260

QGIS crashes on clicking on map canvas

Added by pcreso-pcreso-com - about 15 years ago. Updated about 15 years ago.

Status:Closed
Priority:Low
Assignee:Martin Dobias
Category:Map Canvas
Affected QGIS version: Regression?:No
Operating System:SuSE Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10319

Description

I click on the canvas in any of several modes, with 3 PostGIS layers open. QGIS crashes with the following msg in the invoking text window:

Ok fetching typenam,etc
typOid is: 1700
Ok fetching typelem using
select typelem from pg_type where typelem = 1700 and typlen = -1
poid is: 1700
Ok fetching typenam,etc
Warning: QPainter::begin(): Painter is already active.
You must end() the painter before a second begin()
Segmentation fault

History

#1 Updated by Gavin Macaulay - about 15 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Fixed in svn 7cff7dac (SVN r5763). Problem was probably caused by commit 15bde541 (SVN r5759)

Also available in: Atom PDF