Feature request #2586

Relative paths support or "load other layers from the same location" option

Added by Jhelebrant - over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Project Loading/Saving
Pull Request or Patch supplied: Resolution:invalid
Easy fix?:No Copied to github as #:12646

Description

When moving my project to other folder, I always have to manually edit the QGS file or I have to specify location for each single layer when loading the project although I have them all in one folder.

Would be perfect to have support for relative paths or at least a dialog like "Load other layers from the same location? Yes/No"

thanks much and good luck

History

#1 Updated by Giovanni Manghi over 10 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

relative paths are already supported in qgis trunk. Under windows you can install it with the osgeo4w installer.

#2 Updated by Jhelebrant - over 10 years ago

Replying to [comment:1 lutra]:

relative paths are already supported in qgis trunk. Under windows you can install it with the osgeo4w installer.

Hm,
I am offline at home so this is problem. But someone compiled the 1.5 Trunk c5b9aa5d (SVN r13289) and it behaves in the same way as 1.4 Enceladus. Are you sure, that this was solved in later revisions?

thanks

#3 Updated by Jürgen Fischer over 10 years ago

Replying to [comment:2 jhelebrant]:

I am offline at home so this is problem. But someone compiled the 1.5 Trunk c5b9aa5d (SVN r13289) and it behaves in the same way as 1.4 Enceladus. Are you sure, that this was solved in later revisions?

relative paths are optional: Settings/Project Properties/General/Save Paths

BTW this is a duplicate of #1211

#4 Updated by Jhelebrant - over 10 years ago

Replying to [comment:3 jef]:

relative paths are optional: Settings/Project Properties/General/Save Paths

Ok,
I got it. Thanks much :-)

Also available in: Atom PDF