Feature request #2585

New symbology: change symbols size with scale

Added by Giovanni Manghi over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Symbology
Pull Request or Patch supplied: Resolution:fixed
Easy fix?:No Copied to github as #:12645

Description

Add (with a checkbox?) the possibility have markers size to change depending on scale (when size is defined in map units). More in general this should work for every symbology element where a size can be defined (line width, etc.).

Add also the option to have the size defined by the value of a field in the vector (shapefile/postgis/spatialite) table of attributes.

Screenshot.png (64.1 KB) Giovanni Manghi, 2010-04-26 12:03 PM

History

#1 Updated by Giovanni Manghi over 10 years ago

Markeline symbols (fontmarker, simplemarker and svgmarker) are not resizing accordingly with the scale, when map units are choosen. Also not resizing are intervals and offsets.

#2 Updated by Martin Dobias over 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Added in 02df126b (SVN r13390) (together with data-defined rotation)

#3 Updated by Giovanni Manghi over 10 years ago

  • Resolution deleted (fixed)
  • Status changed from Closed to Feedback

Hi Martin,
markelines symbols still are not resizing when unit is map units, plus it seems that if zoom in enough the markelines symbols go wild. See attached images. The markerline red points are supposed to be regularly above the line...

#4 Updated by Martin Dobias over 10 years ago

Markerline seems to work fine for me. Please could you attach the test data and steps how to reproduce it? Thanks, Martin

#5 Updated by Giovanni Manghi over 10 years ago

Hi Martin,
just compiled the latest code on Ubuntu 10.04 and I still don't see any change. I'll send to you an email with screenshots because are too heavy to be attached here.

#6 Updated by Martin Dobias over 10 years ago

  • Status changed from Feedback to Closed
  • Resolution set to fixed

MarkerLine size with map units fixed in 7479708b (SVN r13422).

Also available in: Atom PDF