Bug report #2564

Ftools probably damage text encoding when joining a DBF table (QGIS Enceladus)

Added by Jhelebrant - over 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:cfarmer -
Category:Python plugins
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12624

Description

Hi,
I did some work with joining DBF table with my shapefile layer. The point layer was saved in CP1250 encoding, the DBF table was created in OOo Calc 3.1 and also saved in CP1250. However, the joining tool in Qgis (Enceladus) is doing something wrong, as I always get damaged strings in my attribute table and our national characters are replaced mostly with “?”, although the joined shapefile was also saved in CP1250 charset.

It looks like FTools are using some internal charset which is different from the one used in both layers.

History

#1 Updated by cfarmer - over 10 years ago

The way that fTools interacts with tables in this tool has been changed, could you please test and confirm if this problem still exists?

Carson

#2 Updated by cfarmer - almost 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

As I have not had any reply to the above comment, I am going to assume the problem no longer persists, and am closing this ticket as "fixed".

Carson

Also available in: Atom PDF