Bug report #2537

Trunk build fails

Added by John Tull over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Build/Install
Affected QGIS version: Regression?:No
Operating System:OS X Easy fix?:No
Pull Request or Patch supplied: Resolution:invalid
Crashes QGIS or corrupts data: Copied to github as #:12597

Description

Current source is failing to build for me with cmake on OS X, qt-4.6.2:

Generating flex_qgssearchstringlexer.cpp
/Users/jctull/sources/qgis/trunk/src/core/qgssearchstringlexer.ll:98: warning, the character range [?-?] is ambiguous in a case-insensitive scanner
flex: fatal internal error, exec failed
/Users/jctull/sources/qgis/trunk/src/core/qgssearchstringlexer.ll:98: warning, the character range [?-?] is ambiguous in a case-insensitive scanner
maker2: * [src/core/flex_qgssearchstringlexer.cpp] Error 141
maker1:
[src/core/CMakeFiles/qgis_core.dir/all] Error 2
make: *
* [all] Error 2

History

#1 Updated by John Tull over 10 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

I sorted this out. Turns out I had a conflicting flex binary added to my path.

Also available in: Atom PDF