Bug report #2511

Mean coordinate(s) tool crashes qgis/throws an error on PostGIS polygonal layers

Added by dr - over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:cfarmer -
Category:Python plugins
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12571

Description

Mean coordinate(s) tool crashes qgis/throws an error on PostGIS polygonal layers, with point and linear layers it works correctly.

[http://gis-lab.info/share/DR/mean-postgis.png]

Associated revisions

Revision 9c076877
Added by Jürgen Fischer over 10 years ago

fix #2511

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision b0a9d994
Added by Jürgen Fischer over 10 years ago

fix #2511

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Giovanni Manghi over 10 years ago

it works fine here under ubuntu 9.10 and qgis trunk. Can you add the polygon you are testing so I will export to my postgis server and test again? thanks.

#2 Updated by dr - over 10 years ago

You can connect to our PostGIS server directly:

1. Host - gis-lab.info

2. Database - geosample

3. Port - 5432

4. Username/password - guest/guest

I've get an error on 'admin' layer.

#3 Updated by Giovanni Manghi over 10 years ago

Hi,

it works for me. No crashes o python error messages with qgis 1.4/trunk under ubuntu 9.04/9.10.

#4 Updated by Jürgen Fischer over 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

looks like this is caused by {{estimated_extent}} doesn't work on your database. b0a9d994 (SVN r13015) copes with that.

Also available in: Atom PDF