Bug report #2478

Action, open browser don`t functions

Added by Gerhard Spieles over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Vectors
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:invalid
Crashes QGIS or corrupts data: Copied to github as #:12538

Description

Layer properties, Action list schould open an application when click on "Actions" in the identify results box of an object in the vector layer.
On windows systems, registrated applications (like ie, firefox, office applications) [email protected] open. The capture output box shows the message "Unable to run command C:\\Programme\\Mozilla Firefox\\firefox.exe http://www.gis-schweich.de/mapserver_schweich_online/"

To resolve the problem, [email protected] tried the "openurl" method (Ticket 1514), but there was no success.

When I run application without entries in the windows registy, the application starts without problems, p.e. FezillaFTP. (capture output message: Starting "C:\\Programme\\FileZilla FTP Client\\filezilla.exe"...
Done")

History

#1 Updated by Gerhard Spieles over 10 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

It ist not really a problem. You have to set the path to the exe file into double paranthese.

The right action command is:

"C:\\Programme\\Mozilla Firefox\\firefox.exe" http://www.gis-schweich.de/mapserver_schweich_online/

Then it functions.

Also available in: Atom PDF