Bug report #2474

QGIS crashes when TOC window width has been changed

Added by jekhor - over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:GUI
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:12534

Description

QGIS crashes when TOC window width has been changed. There is message on console: "Warning: QPaintDevice: Cannot destroy paint device that is being painted".

There is sample project in the attachment

History

#1 Updated by jekhor - over 10 years ago

I am sorry, there is sample data here: http://latlon.org/~jek/qgis-test-crash.tar.bz2

#2 Updated by jekhor - over 10 years ago

Bug reproduces only with render caching enabled.

#3 Updated by jekhor - over 10 years ago

Clarification: Bug reproduces only with Overview enabled.

#4 Updated by Giovanni Manghi over 10 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Hi,
this is duplicate of #2339.

Cheers

Also available in: Atom PDF