Bug report #2473

identify window stays on top of other application's windows with Qt 4.6 Cocoa

Added by William Kyngesburye over 10 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:GUI
Affected QGIS version: Regression?:No
Operating System:OS X Easy fix?:No
Pull Request or Patch supplied: Resolution:invalid
Crashes QGIS or corrupts data: Copied to github as #:12533

Description

When I have an identify results window open, then switch to another application, the identify results window stays in front of the other application. See attached snapshot as I type this in Safari...

It doesn't happen with Qt 4.6 Carbon, so this may be a Qt bug.

identify_results_on_top.png (60.7 KB) William Kyngesburye, 2010-02-25 03:45 PM

History

#1 Updated by William Kyngesburye almost 10 years ago

It also affects the GRASS tools window and some other non-modal informational windows.

This is really annoying, I can't switch to another app in the system without hiding Qgis when one of these windows is open. Anyone have any ideas?

#2 Updated by William Kyngesburye over 9 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

I thought I saw the same issue with Qt 4.7.0, but it seems to be solved with Qt 4.7.1.

Closing as invalid (Qt bug). Solution: use Qt 4.7.1+

Also available in: Atom PDF