Bug report #2462

Composer non-raster print to pdf ignores svg image items

Added by John Tull over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:-
Affected QGIS version: Regression?:No
Operating System:OS X Easy fix?:No
Pull Request or Patch supplied: Resolution:invalid
Crashes QGIS or corrupts data: Copied to github as #:12522

Description

I have a project file with a composer that I am having to print to pdf as a non-raster file. (This is because of some other bug with unusual vector layer color fills that only shows when exporting as a raster...)

I added an svg image to the composer with a 45 degree rotation to serve as a watermark. The final pdf document has all elements except this watermark and my north arrow svg image. For some reason svg image overlays are not being printed when exporting a vetorized pdf.

History

#1 Updated by Marco Hugentobler over 10 years ago

Hm, printing svn pictures seem to work for me here with vector pdf (but the composer pictures are always printed as rasters and embedded as images into the svg).
Is this only a specific svg picture or does it always happen? Are you still on Qt4.6, OS X?

#2 Updated by John Tull over 10 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

It appears to be working for me now as well. Closed

#3 Updated by John Tull over 10 years ago

  • Status changed from Closed to Feedback
  • Resolution deleted (invalid)

Oddly, this issue is again occurring for me in trunk. Can anyone else test? It is as simple as creating a composer map, adding an svg image, such as a north arrow, unchecking the "Print as Raster" option in the General tab, then printing it to a pdf file.

cc01a5ba (SVN r13917) and qt-4.7.0-beta on OS X

#4 Updated by Médéric RIBREUX over 10 years ago

Hello,

I can't reproduce it with a http://trac.osgeo.org/qgis/changeset/13939 under Debian Squeeze... Perhaps is it OSX specific ?

#5 Updated by John Tull over 10 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

This is a strange, and inconsistent bug. Now it works again... Closed

Also available in: Atom PDF