Bug report #2456

Installation of Quantum GIS is impossible, when folder has name "Program Files"

Added by Ghuoargh - over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Build/Install
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:invalid
Crashes QGIS or corrupts data: Copied to github as #:12516

Description

When trying to install - under Windows Vista - Quantum GIS Enceladus into the folder "Program Files" (which is the default name), the files to be installed were "skipped" instead of being installed, and nothing (!) of the program was installed, yet, a message "Quantum GIS has been installed on your computer." or the like appeared. The same problem also occured, when trying to install OSGeo4W and/or GRASS, probably the latter. In one of these both cases, probably GRASS, I was told, that the path should not contain folders with spaces in their name, which was the case with the standard Windows folder "Program Files". Thus, I created a new folder "{Programme}", and installing into this folder (instead of into "Program Files") worked with Quantum GIS and GRASS. ...

By the way, I cannot launch GRASS: The simple "GRASS" or so option does not work (I, however, do not remember the words of the error message), and when using "GRASS with MSYS" or so, a window appears, where I are prompted to choose a folder and a location, which is possible, but I then cannot choose or create a map..., and neither press the button "Start Grass" or the like, for the letters on the respective buttons remain gray, and the buttons cannot be clicked ...

Finally, by the way, the installation of the newest version of OSGeo4W apparently has not worked, for unknown reason, but I currently do not really need it, so I have not expended much efforts on this issue ...

History

#1 Updated by Giovanni Manghi over 10 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

Hi,
one of these problems is known, under Vista/Seven you must launch the installer as administrator (right click on the file -> compatibility -> run as admin - or something like that).

Nevertheless this is not a qgis problem, so you may want to file again this ticket in the osgeo4w trac

http://trac.osgeo.org/osgeo4w/

Also available in: Atom PDF