Bug report #2453

New georeferencer can't read old GCP files

Added by jcrepetto - over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:mmassing -
Category:C++ Plugins
Affected QGIS version: Regression?:No
Operating System:Gentoo Easy fix?:No
Pull Request or Patch supplied: Resolution:wontfix
Crashes QGIS or corrupts data: Copied to github as #:12513

Description

The format of the GCP files written by the georeferencer plugin has changed. The new georeferencer is not able to read GCP files wrtitten by the previous version.

New format :

mapX,mapY,pixelX,pixelY,enable
644074.040000000037253,3424429.160000000149012,324.467273196352892,-377.600958771641899,1
647218.880000000004657,3324465.549999999813735,372.486890980226576,-3103.566308811389263,1
787228.250000000000000,3328856.060000000055879,4195.511146587900839,-3064.490930733335972,1
784047.849999999976717,3428892.689999999944121,4143.457615167902986,-334.467332134857315,1

Old format :

644074.040000000037253    3424429.160000000149012    324.467273196352892    -377.600958771641899
647218.880000000004657    3324465.549999999813735    372.486890980226576    -3103.566308811389263
787228.250000000000000    3328856.060000000055879    4195.511146587900839    -3064.490930733335972
784047.849999999976717    3428892.689999999944121    4143.457615167902986    -334.467332134857315

ouarzazate.jpg.points - GCP file (olf format) (380 Bytes) jcrepetto -, 2010-02-18 05:46 AM

History

#1 Updated by mmassing - over 10 years ago

  • Resolution set to wontfix
  • Status changed from Open to Closed

Hi,

can't reproduce the problem here. For me, the only difference between old and new format (i.e. between the versions produced by the plugin included in 1.4 and 1.5) are the delimiters (in the old format, tab was used as delimiter, whereas the new format uses comma separated values), and the additional "enable" flag for the new version. Version 1.4 files of this type are read
correctly, I am guessing your files are even older?

Anyway, the attached example only differs from the 1.4 format due to the missing header line. As
workaround, you could add a (arbirtrary) header line to your old files. Although the breakage
is unfortunate, I'll mark this as "wontfix" for now - there is an easy workaround, and I don't want to add to much complexity to the loader for a collection of legacy formats.

Feel free to reopen if you feel this bug will affect users strongly.

Also available in: Atom PDF