Bug report #2357

QGIS 1.4 - Crash before launching on MAC OS X Leopard

Added by Ben - almost 12 years ago. Updated almost 12 years ago.

Status:Closed
Priority:Low
Assignee:William Kyngesburye
Category:Build/Install
Affected QGIS version: Regression?:No
Operating System:OS X Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12417

Description

I've dowloaded the following version : http://www.kyngchaos.com/files/software/unixport/Qgis(standalone)-1.4.0-2-Leopard.dmg

After copy/paste in my application folder, impossible to launch the new version of QGIS.

The bug report of the system give the following message :

Process: Qgis r1238
Path: /Applications/Qgis.app/Contents/MacOS/Qgis
Identifier: org.qgis.qgis
Version: ? (?)
Code Type: PPC (Native)
Parent Process: launchd r95

Interval Since Last Report: 2670560 sec
Crashes Since Last Report: 22
Per-App Interval Since Last Report: 0 sec
Per-App Crashes Since Last Report: 9

Date/Time: 2010-01-11 21:24:03.995 +0100
OS Version: Mac OS X 10.5.8 (9L30)
Report Version: 6
Anonymous UUID: A49CED2A-094D-4DBB-9532-AD4061759B1E

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000001, 0x000000008fe0105c
Crashed Thread: 0

Dyld Error Message:
Library not loaded: /Library/Frameworks/PROJ.framework/Versions/4/PROJ
Referenced from: /Applications/Qgis.app/Contents/MacOS/../Frameworks/GDAL.framework/GDAL
Reason: image not found

I think, the package isn't complete, no?
Thanks.

History

#1 Updated by William Kyngesburye almost 12 years ago

Glitch in the bundling step - missed some library paths. New build coming soon.

#2 Updated by William Kyngesburye almost 12 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

New package to fix the problem is available.

Also available in: Atom PDF