Bug report #2311

Print composer template creates identically named composer items

Added by John Tull almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:-
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12371

Description

If you create a composer item, save it to a template, then load the template again, the composer item name is identical and you compromise access to the two identically named composer items from the "Print Composers" menu item. The new composer item should get an index number appended or some other method of producing a new composer item uniquely named relative to the already existing one.

Currently, you will see and have access to only one of the composer items under the "Print Composers" submenu. You have to go to the "Composer Manager" to be able to access each composer item. You can rename from there to work around the issue manually.

History

#1 Updated by Marco Hugentobler almost 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

The problem was that, after the template read, the instance has been unregistered from the composers submenu, but not inserted again.
Also, I think the composer title should not be changed when reading from template file.

b2e7a7c1 (SVN r12613) fixes both issues.

Also available in: Atom PDF