Bug report #2307

Edit widget not working correctly ( show first value instead of the correct one)

Added by pinux - over 9 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Vectors
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12367

Description

When I'm using the Feature form with the edit widget "Unique value" I'm not getting the correct attribute of the feature. I'm getting the first one that is in the list. I have the same problem with shapefile and postgis. I have experienced the same problem even with the another widget.

Unique_value.jpg (78.2 KB) pinux -, 2009-12-21 08:13 AM

History

#1 Updated by Jürgen Fischer over 9 years ago

Replying to pinux:

When I'm using the Feature form with the edit widget "Unique value" I'm not getting the correct attribute of the feature. I'm getting the first one that is in the list. I have the same problem with shapefile and postgis.

Sorry. Works with both for me. Can you provide a testcase?

I have experienced the same problem even with the another widget.

And the other one is?

#2 Updated by pinux - over 9 years ago

It is not working only with Unique value. Here is a screenshot, you can see how the attributes are differen, for the same polygon. The error is present even qith custom forms.

#3 Updated by Jürgen Fischer over 9 years ago

Replying to [comment:2 pinux]:

It is not working only with Unique value. Here is a screenshot, you can see how the attributes are differen, for the same polygon. The error is present even qith custom forms.

looks like it's already fixed in e863e7d5 (SVN r12546). Try to update.

#4 Updated by pinux - over 9 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

It is fixed now.

Also available in: Atom PDF