Bug report #2304

In GRASS plugin, r.water.outlet is not working

Added by Micha Silver almost 11 years ago. Updated almost 11 years ago.

Status:Closed
Priority:Low
Assignee:Lorenzo Masini
Category:GRASS
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:invalid
Crashes QGIS or corrupts data: Copied to github as #:12364

Description

I cannot get expected results with the r.water.outlet GRASS module in QGIS 1.3.0. I've tried in a few different locations, on both win and linux setups, and I always get a uniform raster with value 0 covering the whole region.
I recall this working properly in earlier versions of QGIS (pre-1.0)

To duplicate the issue:
In the North Carolina database, run r.watershed using the elevation raster to create flow direction, streams and catchments rasters. Then run r.water.outlet using the resulting flow direction, and a drainage outlet point on the streams raster. Results are always a black raster covering the whole region.

Working in GRASS, outside of QGIS, using the same GRASS database, flow direction, and same easting-northing values results in a correct drainage basin.

History

#1 Updated by Redmine Admin almost 11 years ago

Works for me (svn trunk) but the output map displayed in qgis with default color map (grayscale) is black.

Are you sure that realy the values are 0, try r.stats -c? Try to change in raster layer options the colormap to pseudo color in qgis.

I believe, that the bug is in qgis in rendering of a layer with values 0 and 1 using grayscale colormap. If you confirm this, please close this ticket as invalid and create a new one for this problem.

#2 Updated by Micha Silver almost 11 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

Quite right! I apologize for mis-reporting. The module r.water.outlet indeed works, but QGIS displays grayscale values of 0 and 1 as all black, so there's no differentiation of the final watershed. Changing the symbology to pseudocolor (or any other color ramp) will show the resulting watershed correctly.

Also available in: Atom PDF