Bug report #2300

Rendering of GRASS RGB composites takes ages

Added by juanelz - over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:Lorenzo Masini
Category:GRASS
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12360

Description

Using qgis Trunk 1.4.0-80 on Windows XP and Grass tools plugin 1.0.2-2 rendering of GRASS rgb composites (created with r.composite) in the map canvas takes very long. After every zoom or pan the extremly slow rendering starts again. This bug seems to be related to https://trac.osgeo.org/qgis/ticket/1816).
In qgis version "Metis" 0.11 the performance of rendering GRASS rasters and composites was very fast.

History

#1 Updated by Redmine Admin over 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

This should be fixed by new GRASS raster provider in 728ecc69 (SVN r12881) , the color table is applied in GRASS module and only colored picture is sent to QGIS. It should not be slower then GRASS.

When GDAL was used to render GRASS rasters, the color table was passed as metadata, if there were too many colors it could have become slow.

Please test.

Also available in: Atom PDF