Feature request #2293

Default styles for spatialite layers

Added by mesajs - about 10 years ago. Updated about 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Data Provider
Pull Request or Patch supplied: Resolution:fixed
Easy fix?:No Copied to github as #:12353

Description

It would be preferable to store default styles for spatialite layers in the database (e.g. in a qml table) instead of the project file. Styles to then automatically load when layers are added to a project.

This approach works well with shapefiles, where the .qml file resides with the other files. Very handy when exporting layers to other users - they don't have to setup layer properties from scratch, and you don't have to provide the documentation to do so.

Associated revisions

Revision 98fd25ec
Added by Jürgen Fischer about 10 years ago

fix #2293

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision 286893af
Added by Jürgen Fischer about 10 years ago

fix #2293

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Jürgen Fischer about 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

kind of duplicate of #1127. Although that didn't seem to work on spatialite layers. Fixed in 286893af (SVN r12605).

defaults styles for spatialite layers are also stored in the qmldb.

Also available in: Atom PDF