Bug report #2234

fTools: Export to new projection

Added by dr - almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:cfarmer -
Category:Python plugins
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12294

Description

1) Open vector layer (attachment);

2) Properties -> General -> Query Builder

3) Set "ID" = '2'

4) Vector -> Data Management Tool -> Export to new projection, choose epsg:3395
5) Try to export to shapefile.
Shapefile is not created.

shape.zip (48.7 KB) dr -, 2009-12-09 12:46 PM

History

#1 Updated by Giovanni Manghi almost 10 years ago

works for me under linux and qgis trunk.

#2 Updated by Giovanni Manghi almost 10 years ago

works for me also under windows.

#3 Updated by dr - almost 10 years ago

Replying to [comment:3 lutra]:

works for me also under windows.

Are you doing step by step? When we set Set "ID" = '2' there is 1 polygon at map canvas?

#4 Updated by Giovanni Manghi almost 10 years ago

Replying to [comment:4 dr]:

Are you doing step by step? When we set Set "ID" = '2' there is 1 polygon at map canvas?

yes, and then the tool export a shapefile with only that polygon in the new projection. In fact if I add it to the canvas and enable otfr I can see the two shapes overlap perfectly.

#5 Updated by dr - almost 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Replying to [comment:5 lutra]:

Replying to [comment:4 dr]:

Are you doing step by step? When we set Set "ID" = '2' there is 1 polygon at map canvas?

yes, and then the tool export a shapefile with only that polygon in the new projection. In fact if I add it to the canvas and enable otfr I can see the two shapes overlap perfectly.

There is no problem at 0c5ea3aa (SVN r12392).

Also available in: Atom PDF