Bug report #2220

Reshape Features works incorrectly with rings(?): shapes differs from postgis/spatialite

Added by dr - almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Digitising
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12280

Description

1. Create new polygonal layer.

2. Create new polygon

3. Add ring (see attachment)

4. Using "Reshape Features" tools cut the ring (see attachment)

At result we have non identifiable ring.

step3.jpg (15.1 KB) dr -, 2009-12-09 12:03 AM

step4.jpg (15.8 KB) dr -, 2009-12-09 12:04 AM

step5.jpg (13.4 KB) dr -, 2009-12-09 12:05 AM

History

#1 Updated by Giovanni Manghi almost 10 years ago

Actually I noticed that the vector layer behaves differently if it is postgis/spatialite or if is a shapefile.

After reshaping, the ring becomes a "part" (an island), then:

*) in postgis/spatialite the island is not selectable nor identifiable. If you use the "select features" tool on the main polygon then it then selects also the island. The identify tool doesn't work the same, as identifying the main polygon do not highlight the island.

*) with shapefiles the resulting island is both selectable and identifiable but only after saving the changes. Before saving changes the island in not identifiable nor selectable, as in the above case.

By the way, is correct the ring become an island after reshaping the polygon?

#2 Updated by Marco Hugentobler almost 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Fixed in f9c0682a (SVN r12586)

Also available in: Atom PDF