Bug report #2214

georeferencer windows passes behind qgis main window when choosing points from canvas

Added by Giovanni Manghi almost 11 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:Tim Sutton
Category:C++ Plugins
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12274

Description

when choosing points and after clicking on "choose from map canvas" and clicking on the canvas, the referencer window passes behind the qgis main window, making necessary to pass it again in front before clicking "ok". If I'm not wrong in the past behaved ok. This happens at least under linux.

History

#1 Updated by mmassing - over 10 years ago

I can't reproduce this with the new georeferencer from SVN trunk.
For me, the qgis main windows is initially raised (upon selection of "Choose From Map Canvas"), but passes behind the georeferencer window again after a point has been selected in the map canvas, so the button is easily accessible (tested under KDE4/linux).

Can you test the new georeferencer from SVN trunk and report back if it still is an issue for you?

#2 Updated by Giovanni Manghi over 10 years ago

Hi,

this ticket was about the old georeferencer. I'll test the new and let you know. Thanks!

#3 Updated by Giovanni Manghi over 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Hi,

just tested the new georeferencer and it works really fine! closing this.

PS
I just found the following:
when you are about to create the new georeferenced raster you need to choose the "targer srs". If you choose a custom srs (one defined in the "custom crs" menu) it shows instead a "EPSG:0". The resulting raster it does not have the correct srs applied. Do you want me to open a new ticket?

#4 Updated by mmassing - over 10 years ago

Thank you for looking into this.
It'd be great if you could file the custom crs issue as a new bug.

Also available in: Atom PDF