Bug report #2210

fTools: Select by location works only within current extent

Added by dr - almost 11 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:cfarmer -
Category:Python plugins
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12270

Description

Select by location works only within current extent.

Associated revisions

Revision 95382e64
Added by cfarmer - over 10 years ago

Select by location now works on full layer extent. Fixes #2210.

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision e2d0f006
Added by cfarmer - over 10 years ago

Select by location now works on full layer extent. Fixes #2210.

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Giovanni Manghi almost 11 years ago

Is this actually a bug?

I mean, maybe it was not on purpose, but it can be pretty handy as "feature". After all to work as it is supposed you just need to make a zoom to the full extent of the location you want to use to select features...

#2 Updated by Maxim Dubinin almost 11 years ago

If this is not a bug, it is definitely not user friendly. Why is this working on the extent while other tools do not? This is definitely a handy mode, but, like "work on selected" should be optional and switchable, not default. User might not understand that he needs to Zoom to full extent.

#3 Updated by Giovanni Manghi almost 11 years ago

agree

#4 Updated by cfarmer - over 10 years ago

  • Status changed from Open to In Progress

Fixed in e2d0f006 (SVN r13916). Now works on full layer extent.

Carson

#5 Updated by cfarmer - over 10 years ago

  • Resolution set to fixed
  • Status changed from In Progress to Closed

Also available in: Atom PDF