Bug report #21928

editing in spatial oracle

Added by rawan gis 7 months ago. Updated 7 months ago.

Status:Open
Priority:High
Assignee:-
Category:Data Provider/Oracle
Affected QGIS version:3.6.2 Regression?:Yes
Operating System:windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:29743

Description

Hi
I have a layer stored in spatial oracle database, the layer has ESRI Auto-Incrementing ObjectID Field , in all QGIS 3 version this field was not generated automatically and it is need to be assigned manually.kindly see the attached file which shows a case for this bug
regards

oracleediting.jpg (230 KB) rawan gis, 2019-04-25 08:43 AM

History

#1 Updated by rawan gis 7 months ago

rawan gis wrote:

Hi
I have a layer stored in spatial oracle database, the layer has ESRI Auto-Incrementing ObjectID Field , in all QGIS 3 version the value of this field was not generated automatically and it needs to be assigned manually to complete the editing of any new added feature.kindly see the attached image which shows a case for this bug
regards

#2 Updated by Giovanni Manghi 7 months ago

  • Status changed from Open to Feedback
  • Category changed from Editing to Data Provider/Oracle

rawan gis wrote:

Hi
I have a layer stored in spatial oracle database, the layer has ESRI Auto-Incrementing ObjectID Field , in all QGIS 3 version this field was not generated automatically and it is need to be assigned manually.kindly see the attached file which shows a case for this bug

meaning this was working as expected in QGIS 2.*?

#3 Updated by rawan gis 7 months ago

  • Assignee set to Giovanni Manghi

yes it was working as expected in QGIS2.x

#4 Updated by Giovanni Manghi 7 months ago

  • Regression? changed from No to Yes
  • Status changed from Feedback to Open
  • Assignee deleted (Giovanni Manghi)

Also available in: Atom PDF