Bug report #21914

Layer Properties - Attributes Forms - Value Map not using Value, uses Description for field value

Added by Nigel Luckman 12 months ago. Updated 12 months ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Forms
Affected QGIS version:3.6.2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:29729

Description

Selecting Widget Type - Value Map for a field and loading value and description from either 'Load Data from Layer' or 'Load Data from CSV File' always results in the Description field being entered into the field, not the value, when the Description in the dropdown pick list is selected.

History

#1 Updated by Giovanni Manghi 12 months ago

  • Resolution set to invalid
  • Operating System deleted (Windows 10 64 bit)
  • Status changed from Open to Closed

This is by design:

in the project where you are using the value map you will always see what you defined in the "description", but in the datasource it is written what you have defined in the "value". Just check by opening the datasource in a blank project.

Also available in: Atom PDF