Bug report #21913

attribute header names are not saved

Added by rawan gis 7 months ago. Updated 7 months ago.

Status:Open
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:3.6.2 Regression?:No
Operating System:windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:29728

Description

Hello
when adding attribute table to the layout,the header name for fields can be changed but it will not be saved, so if I closed QGIS and open it again the header name will be the original name.
regards

headercustumized.pdf (4.46 MB) rawan gis, 2019-04-24 07:23 AM

headernotsaved.pdf (4.47 MB) rawan gis, 2019-04-24 07:24 AM

attributesheader.jpg (547 KB) rawan gis, 2019-04-24 07:49 AM

atlas2.rar (129 KB) rawan gis, 2019-04-24 02:21 PM

History

#1 Updated by Giovanni Manghi 7 months ago

  • Status changed from Open to Feedback
  • Easy fix? changed from Yes to No

Cannot confirm here on Linux. Can you attach a sample project and sample data that shows this problem? Thanks.

#2 Updated by rawan gis 7 months ago

HI
the attached file include two pdf files one with the column header customized and the other show that the customized header was not saved.
Regards

#3 Updated by rawan gis 7 months ago

HI
the attached file include two pdf files one with the column header customized and the other show that the customized header was not saved although I saved both the layout and the project this problem appears in any project regarding the data in all QGIS 3 versions
Regards

#4 Updated by Giovanni Manghi 7 months ago

rawan gis wrote:

HI
the attached file include two pdf files one with the column header customized and the other show that the customized header was not saved although I saved both the layout and the project this problem appears in any project regarding the data in all QGIS 3 versions
Regards

please attach an actual sample project+data

#5 Updated by rawan gis 7 months ago

thanks. I think it is fixed now but if the layout with the attribute is created using previous versions then the attribute table should be deleted and added again to save the header

#6 Updated by Giovanni Manghi 7 months ago

rawan gis wrote:

thanks. I think it is fixed now but if the layout with the attribute is created using previous versions then the attribute table should be deleted and added again to save the header

I would love to try a project where is possible to see this issue...

#7 Updated by rawan gis 7 months ago

kindly see the attached project in which the layout has an attribute that was added in QGIS version 2.18 and its header can not be saved .its small project since the allowed uploaded only 5mb
regards

#8 Updated by Giovanni Manghi 7 months ago

  • Status changed from Feedback to Open
  • Subject changed from attribute header to attribute header names are not saved
  • Category changed from Attribute table to Map Composer/Printing

Also available in: Atom PDF