Bug report #2191

Attribute table: edit text window size not matching column width

Added by Donkagen2 - almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:Jürgen Fischer
Category:GUI
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12251

Description

If the attribute table column width is increased from the default, when editing a text field the visible editing text string doesn't match the column width.

History

#1 Updated by Borys Jurgiel almost 10 years ago

I fixed a similar problem with the widget resize in 9ad21f7c (SVN r12035), but due to changes in it's broken again and I can't manage to set the widget resizing policy. Jürgen heeeeelp...

It's, however, better than was, because previously columns were being shrinked to a default size of the widget.

#2 Updated by Borys Jurgiel almost 10 years ago

The problem is in line 88 of qgsattributetabledelegate.cpp:

editor->adjustSize();

It makes the widget always adjusting to its default size. I'd remove this line, however it's good for one widget class: the file selector, what is higher than the row height. What about testing the editor class and adjusting only if it's the file selector?

#3 Updated by Jürgen Fischer almost 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

fixed in e863e7d5 (SVN r12546)

Also available in: Atom PDF