Bug report #21902

Fails to build with GDAL 2.5.0-beta1

Added by Bas Couwenberg 9 months ago. Updated 9 months ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Build/Install
Affected QGIS version:3.4.6 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:29717

Description

QGIS 3.4.7 fails to build with GDAL 2.5.0-beta1:

../../src/core/qgscoordinatereferencesystem.cpp: In member function 'bool QgsCoordinateReferenceSystem::createFromWkt(const QString&)':
../../src/core/qgscoordinatereferencesystem.cpp:641:5: error: 'OSRFixup' was not declared in this scope
     OSRFixup( d->mCRS );
     ^~~~~~~~

From https://github.com/OSGeo/gdal/blob/v2.5.0beta1/gdal/MIGRATION_GUIDE.TXT:

  • removal of OSRFixup() and OSRFixupOrdering(): no longer needed since objects constructed are always valid

Associated revisions

Revision 0f315e47
Added by Jürgen Fischer 9 months ago

avoid OSRFixup with GDAL >= 2.5 (fixes #21902)

(cherry picked from commit 9a8c0d28982f3c31dc0f7c8a2f796c85ec801191)

History

#1 Updated by Jürgen Fischer 9 months ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF