Bug report #21872

QGIS 3.7 did not start because an error message

Added by Torsten Hase 12 months ago. Updated 12 months ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Python bindings / sipify
Affected QGIS version:3.7(master) Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:29687

Description

QGIS does not start properly and gives following error message:

Fehler bei der Ausführung folgenden Codes:
qgis.utils.updateAvailablePlugins()

Traceback (most recent call last):
  File "", line 1, in 
RuntimeError: lost sys.stdout

Python-Version:
3.7.0 (v3.7.0:1bf9cc5093, Jun 27 2018, 04:59:51) [MSC v.1914 64 bit (AMD64)]

QGIS-Version:
3.7.0-Master 'Master', 9ce1093bce

Python-Pfad:
['E:/Programme/osgeo4w/apps/qgis-dev/./python', 'C:/Users/Torsten/AppData/Roaming/QGIS/QGIS3\\profiles\\default/python', 'C:/Users/Torsten/AppData/Roaming/QGIS/QGIS3\\profiles\\default/python/plugins', 'E:/Programme/osgeo4w/apps/qgis-dev/./python/plugins', 'E:\\Programme\\osgeo4w\\bin\\python37.zip', 'E:\\Programme\\osgeo4w\\apps\\Python37\\DLLs', 'E:\\Programme\\osgeo4w\\apps\\Python37\\lib', 'E:\\Programme\\osgeo4w\\bin', 'E:\\Programme\\osgeo4w\\apps\\Python37', 'E:\\Programme\\osgeo4w\\apps\\Python37\\lib\\site-packages', 'E:\\Programme\\osgeo4w\\apps\\Python37\\lib\\site-packages\\win32', 'E:\\Programme\\osgeo4w\\apps\\Python37\\lib\\site-packages\\win32\\lib', 'E:\\Programme\\osgeo4w\\apps\\Python37\\lib\\site-packages\\Pythonwin', 'C:/Users/Torsten/AppData/Roaming/QGIS/QGIS3\\profiles\\default/python']

Associated revisions

Revision 3d7c711d
Added by Jürgen Fischer 12 months ago

fix #21872 (refs #21774; partly reverts e57d1e06f0 and 507e327c0c)

src/python/qgspythonutilsimpl.cpp:596 produces "lost sys.stdout" when
qgis.utils.updateAvailablePlugins() returns.

Revision 40c790f5
Added by Jürgen Fischer 12 months ago

fix 3d7c711db (refs #21872)

History

#1 Updated by Borys Jurgiel 12 months ago

  • Operating System set to Windows
  • Assignee deleted (Borys Jurgiel)
  • Category changed from Plugin Manager to Python bindings / sipify

#2 Updated by Jürgen Fischer 12 months ago

  • Assignee set to Alessandro Pasotti

Duplicate of #21774 - apparently reintroduced by e57d1e06f0 and/or 507e327c0c

#3 Updated by Jürgen Fischer 12 months ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

#4 Updated by Jürgen Fischer 12 months ago

  • Resolution set to fixed/implemented
  • Description updated (diff)
  • Assignee deleted (Alessandro Pasotti)

Also available in: Atom PDF