Bug report #2179

Cannot connect to any spatialite database

Added by Giovanni Manghi almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Data Provider
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12239

Description

Tested on trunk on both linux and windows. Worked until not many revisions ago. Works for sure on qgis 1.3

Associated revisions

Revision 5823e97d
Added by Jürgen Fischer almost 10 years ago

fix #2179

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision a1b0f200
Added by Jürgen Fischer almost 10 years ago

fix #2179

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Jürgen Fischer almost 10 years ago

maybe related to the spatialite update to 2.3. See [ttp://lists.osgeo.org/pipermail/qgis-developer/2009-December/008538.html qgis-developer]:

> - Spatialite: apparently current trunk cannot load SL files (all well on
> Linux though)

Do you use a spatialite 2.3 dataset?  My 2.2 dataset doesn't seem to work as
the provider queries a field named "read_only" which doesn't exist in
"geometry_columns".

#2 Updated by Giovanni Manghi almost 10 years ago

Replying to [comment:1 jef]:

maybe related to the spatialite update to 2.3. See [ttp://lists.osgeo.org/pipermail/qgis-developer/2009-December/008538.html qgis-developer]:

I used the 2.3 sample dataset.

#3 Updated by Jürgen Fischer almost 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

fixed in a1b0f200 (SVN r12313).

Also available in: Atom PDF