Bug report #21782

QGIS macOS plug-ins error install

Added by Aaron Charles Yu over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Python plugins
Affected QGIS version:3.4.5 Regression?:No
Operating System:macOS 10.3 High Sierra Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:29597

Description

Can't install multiple types of plug-in due to missing libraries (i.e. numpy, scipy, and matplotlib)
These libraries weren't included in the installation on a macOS installer, unlike in windows installer there were no issue in installing plug-ins.

Screen Shot 2019-04-06 at 17.13.57.png (305 KB) Aaron Charles Yu, 2019-04-06 11:17 AM

History

#1 Updated by Giovanni Manghi over 1 year ago

  • Assignee deleted (Borys Jurgiel)
  • Status changed from Open to Closed
  • Resolution set to invalid

You must install them by your own (as on Linux): https://www.kyngchaos.com/software/python/

#2 Updated by Jürgen Fischer over 1 year ago

  • Description updated (diff)
  • Category changed from Plugin Manager to Python plugins
  • Resolution deleted (invalid)
  • Priority changed from High to Normal

#3 Updated by Jürgen Fischer over 1 year ago

  • Resolution set to invalid

#4 Updated by Aaron Charles Yu over 1 year ago

Giovanni Manghi wrote:

You must install them by your own (as on Linux): https://www.kyngchaos.com/software/python/

i already did, but it somehow doesn't locate the libraries? or detect the libraries installed.

Also available in: Atom PDF