Bug report #2177

OGR converter: CSV export is broken

Added by Markus Neteler almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:Borys Jurgiel
Category:Python plugins
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:12237

Description

In trunk, the conversion of a SHAPE file (points) to CSV fails. It creates an empty ASCII file.
Additionally, the button description is felt to be confusing: "Dataset" does not indicate that a directory is meant.

Second bug: if the "Dataset" directory already exists, the converter fails with "Failed to create...". In the shell terminal a message is seen that it already exists: it would be important to catch this directory-present error and ask the user to suggest a different name.

"Layer" as button description is also unclear (for CSV): indeed a file name is meant.

See also attachment.

ogr_converter.png - problems in OGR converter interface (button descriptions) (35.8 KB) Markus Neteler, 2009-12-02 06:03 AM

History

#1 Updated by Jürgen Fischer almost 10 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #2176

Also available in: Atom PDF