Bug report #21740

Aggregate processing tool - Group by expression ($geometry) doesn't work

Added by Brent Edwards about 1 year ago. Updated about 1 year ago.

Status:Feedback
Priority:Normal
Assignee:-
Category:Processing/QGIS
Affected QGIS version:3.6.0 Regression?:No
Operating System:Windows 10 Professional Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:29555

Description

As the title states, when attempting to aggregate by geometry the results are inconclusive.

I tested the following expressions on a selection set of 2 identical polygons and they all produced the same result set of 2 polygons:

1) $geometry
2) geom_to_wkt($geometry)
3) centroid($geometry)

I was able to get the correct results by simply creating a virtual field with the same expression (ex. geom_to_wkt($geometry)) and the tool produced the correct result (single polygon with the agg fields).

History

#1 Updated by Giovanni Manghi about 1 year ago

  • Status changed from Open to Feedback

Just tried here on a random polygon shapefile and geom_to_wkt($geometry) worked as expected (aggregation two polygons with identical geometries).

Also available in: Atom PDF