Bug report #21538

QGIS 3.6 crashes when setting elevation layer in QGIS 3D

Added by Jeremy Palmer 11 months ago. Updated 11 months ago.

Status:Closed
Priority:High
Assignee:Martin Dobias
Category:3D
Affected QGIS version:3.6.0 Regression?:No
Operating System:macOS Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:29354

Description

Occurs when I have this WMTS (https://tiles.maps.linz.io/nz_aerialimagery_basemap/WMTSCapabilities.xml) and this DEM layer (https://www.dropbox.com/s/2qrln1znioly22t/lds-tile-ll-GTiff.zip?dl=1) added to the project. When I launch the 3D view it's ok, but when I try to set the elevation layer in the 3D config and select ok it crashes QGIS. No other default QGIS 3D setting were changed.

Using the NZTM WMTS tilematrix and EPSG:2193 as the canvas projection.

See stack trace on MacOS https://gist.github.com/palmerj/b645e4ccd4595a6f3be21affca7eb969

Associated revisions

Revision 4a6151ab
Added by Martin Dobias 11 months ago

[3d] fix crash when switching terrain generator (fixes #21538)

The problem was introduced in PR #8828 when fixing issue #20963

This fix immediately deletes terrain entity on generator change
and informs other code about that + identify map tool is now aware
of the fact that terrain entity may be temporarily null.

Revision 8e9250a0
Added by Martin Dobias 11 months ago

[3d] fix crash when switching terrain generator (fixes #21538)

The problem was introduced in PR #8828 when fixing issue #20963

This fix immediately deletes terrain entity on generator change
and informs other code about that + identify map tool is now aware
of the fact that terrain entity may be temporarily null.

Revision bdcacd71
Added by Martin Dobias 11 months ago

Merge pull request #9465 from wonder-sk/fix-terrain-change-crash

[3d] fix crash when switching terrain generator (fixes #21538)

Revision 56e98f2b
Added by Martin Dobias 11 months ago

[3d] fix crash when switching terrain generator (fixes #21538)

The problem was introduced in PR #8828 when fixing issue #20963

This fix immediately deletes terrain entity on generator change
and informs other code about that + identify map tool is now aware
of the fact that terrain entity may be temporarily null.

Revision bb7ac8f0
Added by Martin Dobias 11 months ago

[3d] fix crash when switching terrain generator (fixes #21538)

The problem was introduced in PR #8828 when fixing issue #20963

This fix immediately deletes terrain entity on generator change
and informs other code about that + identify map tool is now aware
of the fact that terrain entity may be temporarily null.

(cherry picked from commit 4a6151ab481322b44fe4b02e190b9835e714e528)

History

#1 Updated by Giovanni Manghi 11 months ago

  • Crashes QGIS or corrupts data changed from No to Yes
  • Operating System changed from MacOSX to macOS
  • Priority changed from Normal to High

#2 Updated by Martin Dobias 11 months ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF