Bug report #215

svg export doesn't do text

Added by Gavin Macaulay - about 14 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Steven Bell -
Category:-
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10274

Description

The save as svg option in the map composer doesn't include any of the text from the composer items (e.g., legend text, a label, and even text labels on map features).

This looks like a problem with Qt's support for svg rather than a qgis problem.

History

#1 Updated by Tim Sutton about 13 years ago

Changed to minor under the following scheme:
  • blocker - bugs that should block the release. Since we are going to release pretty much 'come what may' I would like no bugs
  • allocated to this category without consultation with me and / or PSC
  • critical - bugs that cause the application to crash or corrupt data
  • major - application features that do not function at all
  • minor - features that function but imerfectly e.g. labels placing incorrectly
  • trivial - gui useability issues or small issues with the documentation, install notes etc.

Reassigned to Steven Bell who is working on composer stuff lately

#2 Updated by Steven Bell - over 12 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

This appears to be fixed with the switch to QSvgGenerator.

#3 Updated by Anonymous about 11 years ago

Milestone Version 0.9.2 deleted

Also available in: Atom PDF