Bug report #21467

Install OSGEO4W broken for QGIS 2.18.28-2 old LTR

Added by Arnaud Poncet-Montanges over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Build/Install
Affected QGIS version:3.4.5 Regression?:Yes
Operating System:Win 7-10 x64 Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:Yes Copied to github as #:29284

Description

Multiple DLL errors when installing QGIS 2.18.28-2 OLD LTR using osgeo4w

OSGEO4W_double_LTR.png - Double LTR (70 KB) Arnaud Poncet-Montanges, 2019-03-04 12:57 PM

History

#1 Updated by Jürgen Fischer over 1 year ago

  • Resolution set to invalid
  • Status changed from Open to Closed

QGIS 2.18 is EOL. Install 3.4 or 3.6 (but there's also a qgis-218 package available if you uncheck "hide obsolete")

#2 Updated by Arnaud Poncet-Montanges over 1 year ago

No need for hide obsolete :

Check qgis-ltr for 3.4.5-1 (don't try 2.18 option here)

Check qgis218 for 2.18.28-2

See linked image for more visual information.

Really useful for QGIS 2 to QGIS 3 migration.

#3 Updated by Jürgen Fischer over 1 year ago

Arnaud Poncet-Montanges wrote:

No need for hide obsolete :

fixed.

Also available in: Atom PDF