Bug report #21462

Join undoes itself

Added by Patrick Sheridan about 1 year ago. Updated about 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Vectors
Affected QGIS version:3.4.2 Regression?:No
Operating System:Windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:29279

Description

I am trying to make a map using a .shp file and an Excel doc. In order to properly use the data, I join the OBJECTID in the .shp to a identically-named column in the Excel doc. This has been working normally, however, I ran into some issues today. I clicked on the Attribute Table to verify the join and it initially appeared to be successful. When I went to update the symbology in my .shp file with a .qml file, however, the proper column found in the Excel doc did not appear as an option. I then returned to the Attribute Table, only to discover that that column was no longer in the table. I am not sure why the join did not work as normal as previously such joins have been successful using the same process.

History

#1 Updated by Giovanni Manghi about 1 year ago

  • Status changed from Open to Feedback

Please attach a sample dataset that can be used to replicate the issue.

#2 Updated by Patrick Sheridan about 1 year ago

It appears that the issue is simply user error. I was joining the wrong layers.

#3 Updated by Giovanni Manghi about 1 year ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

Also available in: Atom PDF