Bug report #21361

QGIS 3.6 CRS Selector not closing/Cannot Select CRS

Added by Scott Atkinson almost 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Projection Support
Affected QGIS version:3.6.0 Regression?:Yes
Operating System:Linux Mint 19.1 Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:29178

Description

Newly updated qgis 3.6. Attempting to load any layer (vector, raster, any) instantly pulls up the CRS Select Dialogue (without even selecting a file at that point). Selection of any CRS isn't accepted and the dialogue will not close. epsg:4326 (default, is also missing from any CRS options). Log output also mentions that /usr/share/qgis/resources/data/world_map.shp cannot be opened. I have to manually kill qgis to close down.

Updated from 3.4 to 3.6 using apt and standard ubuntu repos.

Similar to the previous (now closed) bug report: Bug report #18405

History

#1 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Open to Feedback

I just tried on osgeo4w (cannot update on ubuntu now) and cannot confirm.

#2 Updated by Scott Atkinson over 1 year ago

My ubuntu update seems to have deleted most common CRSs and/or is not pointing to them. Attempting to downgrading to 2.18 even shows them all as missing. Log Messages are now giving "CRITICAL Resource Location Error".

After some poking around I am able to fix the issue and get QGIS 3.6 working again by replacing /usr/share/qgis/resources/srs.db with a new copy of srs.db pulled directly from github.

#3 Updated by Giovanni Manghi over 1 year ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

Also available in: Atom PDF