Bug report #21349

QGIS Clip and Difference - GEOS geoprocessing error: intersection failed.

Added by Lene Fischer over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/Core
Affected QGIS version:3.5(master) Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:29167

Description

Trying to clip and difference vector layers. But it fails.

Tride both Geopackage and SHP same result.
The datasets has been checked in topology checker.

Attached file. Use layer gravplads against gravsted

test.gpkg (500 KB) Lene Fischer, 2019-02-22 07:24 PM

History

#1 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Open to Feedback

Hi Lene, there is no "gravplads" layer in the gpkg.

#2 Updated by Lene Fischer over 1 year ago

  • File deleted (kirkegaard.gpkg)

#3 Updated by Lene Fischer over 1 year ago

  • File kirkegaard.gpkg added

#4 Updated by Lene Fischer over 1 year ago

  • File deleted (kirkegaard.gpkg)

#5 Updated by Lene Fischer over 1 year ago

  • Subject changed from Clip - GEOS geoprocessing error: intersection failed. to QGIS Clip and Difference - GEOS geoprocessing error: intersection failed.
  • File test.gpkg added

I have uploadet a smaller geopackage

#6 Updated by Giovanni Manghi over 1 year ago

Just one more case of the inconsistency that we have in the tools to check geometries: as I raised a few times in the past they all yields different results.

If you fix your layers with the "fix geometries" tool (that is based on the excellent st_makevalid) then the operation runs without issues...

#7 Updated by Lene Fischer over 1 year ago

So sorry - I thought that checking with the topology checker was the best method to control features.
When there was no errors I didn´t run the fix geometries.

#8 Updated by Giovanni Manghi over 1 year ago

Lene Fischer wrote:

So sorry - I thought that checking with the topology checker was the best method to control features.

the topology checker (that despite the name can also check for geometry issues) is great, as a simple way foe users to choose what they want to check, it does not fix anything... so is bit limited

the geometry checker (that despite the name can also check for topolgy issues) gives a lot of options, can fix errors... but honestly is not a great ux

the two above usually yeld slightly different results

anyway, if you want to fix geometries without worrying about parameters, etc... just use postgis st_makevalid (st_IsValidReason if you want to know what error is) or its QGIS incarnation.

closing?

#9 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Feedback to Closed
  • Resolution set to invalid

I'm closing Lene because the real problem is the total inconsistency we have among the tools that can check/fix geometries. This issue should really need to be addressed, not even sure if a ticket would be the right starting point.

Also available in: Atom PDF