Bug report #21307

Crash on Edit Vertex

Added by Gabriel De Luca almost 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Digitising
Affected QGIS version:3.5(master) Regression?:No
Operating System:Windows 10 64 bit Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:Yes Copied to github as #:29125

Description

In Windows 10, 64bit.

qgis 3.4.4-3 and qgis-dev 3.5.0-96
libspatialindex 1.9.0-1 (I was seeing other issues and maybe it's relevant).

With a clean profile. Without plugins.

We can't edit a vertex without a crash.

Crash ID: 29e477876482ac467807c080b89d67c79639207a

Stack Trace

QUndoStack::endMacro :
QVector::removeAt :
QgisApp::actionAbout :
QStyledItemDelegate::setModelData :
QgisApp::actionAbout :
QAbstractItemView::commitData :
QMetaObject::activate :
QAbstractItemDelegate::~QAbstractItemDelegate :
QObject::event :
QApplicationPrivate::notify_helper :
QApplication::notify :
QVector::removeAt :
QCoreApplication::notifyInternal2 :
QCoreApplicationPrivate::sendPostedEvents :
qt_plugin_query_metadata :
QEventDispatcherWin32::processEvents :
CallWindowProcW :
DispatchMessageW :
QEventDispatcherWin32::processEvents :
qt_plugin_query_metadata :
QEventLoop::exec :
QCoreApplication::exec :
QgisApp::actionAbout :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.5.0-Master
QGIS code revision: b711ef01f8
Compiled against Qt: 5.11.2
Running against Qt: 5.11.2
Compiled against GDAL: 2.4.0
Running against GDAL: 2.4.0

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 10.0.17134

vertex.zip - Project and data attached. (8.18 KB) Gabriel De Luca, 2019-02-19 03:48 AM

vertex.png - Screencast attached. (3.86 MB) Gabriel De Luca, 2019-02-20 04:57 PM

History

#1 Updated by Giovanni Manghi almost 2 years ago

  • Operating System changed from Winows 10, 64 bit. to Windows 10 64 bit
  • Status changed from Open to Feedback
  • Priority changed from Normal to High

Tested 3.4.4 and master on a clean Windows environment, no crashes.

#2 Updated by Gabriel De Luca almost 2 years ago

Giovanni Manghi wrote:

Tested 3.4.4 and master on a clean Windows environment, no crashes.

I have started Windows in safe mode.
I have permanently deleted the OSGeo4W, AppData\Local\QGIS and Roaming\QGIS folders. (I don't have a previous stand-alone install in this machine.)
I have repaired the registry keys.
I have installed QGIS again.
I have rebooted the system in each step.

And it continues to fail.

Any idea where the inconvenience may be?
I'm missing a step to clean up the environment?
(I can not format drive C.)

#3 Updated by Giovanni Manghi almost 2 years ago

Gabriel De Luca wrote:

Giovanni Manghi wrote:

Tested 3.4.4 and master on a clean Windows environment, no crashes.

I have started Windows in safe mode.
I have permanently deleted the OSGeo4W, AppData\Local\QGIS and Roaming\QGIS folders. (I don't have a previous stand-alone install in this machine.)
I have repaired the registry keys.
I have installed QGIS again.
I have rebooted the system in each step.

And it continues to fail.

Any idea where the inconvenience may be?
I'm missing a step to clean up the environment?
(I can not format drive C.)

add the exact steps you follow, or even better attach a screencast.

#4 Updated by Gabriel De Luca almost 2 years ago

Giovanni Manghi wrote:

add the exact steps you follow, or even better attach a screencast.

Screencast attached.

#5 Updated by Richard Duivenvoorde almost 2 years ago

Confirmed here with current QGIS master (on Linux):

project epsg:4326
create a new point layer and save as geopackage
add 2 points
go to edit vertex
change x coordinate to 0
crash

Could it be related to: #21325 ?

#6 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Feedback to Open

#7 Updated by Martin Dobias almost 2 years ago

I cannot replicate.

Richard, can you post your traceback from linux?

#8 Updated by Martin Dobias almost 2 years ago

Also, does it need to be a geopackage? would it crash with a temporary scratch layer too? What if you first save the newly added points - would it crash anyway?

#9 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Open to Feedback

#10 Updated by Gabriel De Luca almost 2 years ago

Martin Dobias wrote:

Also, does it need to be a geopackage? would it crash with a temporary scratch layer too? What if you first save the newly added points - would it crash anyway?

In my case, it does not need to be a geopackage. It can be a temporary layer. Also a shapefile.

It does not need to be a points layer, can be linestrings or polygons.

Also, does not need to be when changing the coordinate to zero. Can be any integer or decimal number.

And it does not need to be in EPSG:4326. Can be any CRS.

Saving the edits don't avoid the crash.

But does not always crash on the first edit. My best record was to make three consecutive edits-saves without a crash.

#11 Updated by Gabriel De Luca almost 2 years ago

I can't reproduce it now after install qgis-dev-3.5.0-100.

It was fixed?

#12 Updated by Giovanni Manghi almost 2 years ago

  • Resolution set to fixed/implemented

Gabriel De Luca wrote:

I can't reproduce it now after install qgis-dev-3.5.0-100.

It was fixed?

reopen if necessary.

#13 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF