Bug report #21253

QGIS crashes when adding tif raster layer

Added by Giovanni Manghi over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:Jürgen Fischer
Category:Rasters
Affected QGIS version:3.5(master) Regression?:Yes
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:Yes Copied to github as #:29071

Description

Tested on the latest 3.4.4 and master on OSGeo4w on a clean Windows environment.

Try add a raster layer (d&d, browser, data source manager) --> crash

History

#1 Updated by Jürgen Fischer over 1 year ago

  • Status changed from Open to Feedback

Neither reproducable with build of af723c4942 (qgis-3.4.4-3) nor c327dec672 (qgis-rel-dev-3.4.4-12) inserting landcover.img here.

#2 Updated by Giovanni Manghi over 1 year ago

Jürgen Fischer wrote:

Neither reproducable with build of af723c4942 (qgis) nor c327dec672 (qgis-rel-dev) inserting landcover.img here.

with .img is ok, try SR_50M_alaska_nad.tif

#3 Updated by Jürgen Fischer over 1 year ago

  • Subject changed from QGIS crashes when adding any raster layer to QGIS crashes when adding tif raster layer

#4 Updated by Jürgen Fischer over 1 year ago

  • Assignee set to Jürgen Fischer

#5 Updated by Jürgen Fischer over 1 year ago

  • Operating System set to Windows

#6 Updated by Jorge Rocha over 1 year ago

Not happens on Ubuntu 3.4.4-Madeira.

Is the image ok? maybe corrupted? Can you run gdalinfo on it?

[email protected]:~/tmp$ gdalinfo SR_50M_alaska_nad.tif
Driver: GTiff/GeoTIFF
Files: SR_50M_alaska_nad.tif
       SR_50M_alaska_nad.tif.aux.xml
Size is 1754, 1394
Coordinate System is:
PROJCS["NAD27 / Alaska Albers",
    GEOGCS["NAD27",
        DATUM["North_American_Datum_1927",
            SPHEROID["Clarke 1866",6378206.4,294.9786982138982,
                AUTHORITY["EPSG","7008"]],
            AUTHORITY["EPSG","6267"]],
        PRIMEM["Greenwich",0,
            AUTHORITY["EPSG","8901"]],
        UNIT["degree",0.0174532925199433,
            AUTHORITY["EPSG","9122"]],
        AUTHORITY["EPSG","4267"]],
    PROJECTION["Albers_Conic_Equal_Area"],
    PARAMETER["standard_parallel_1",55],
    PARAMETER["standard_parallel_2",65],
    PARAMETER["latitude_of_center",50],
    PARAMETER["longitude_of_center",-154],
    PARAMETER["false_easting",0],
    PARAMETER["false_northing",0],
    UNIT["US survey foot",0.3048006096012192,
        AUTHORITY["EPSG","9003"]],
    AXIS["X",EAST],
    AXIS["Y",NORTH],
    AUTHORITY["EPSG","2964"]]
Origin = (-6232946.672697668895125,9275122.968681415542960)
Pixel Size = (7181.354110795283304,-7181.354110795283304)
Metadata:
  AREA_OR_POINT=Area
Image Structure Metadata:
  INTERLEAVE=BAND
Corner Coordinates:
Upper Left  (-6232946.673, 9275122.969) (155d 9'54.55"E, 68d31'21.58"N)
Lower Left  (-6232946.673, -735684.662) (177d59'23.96"W, 44d46'59.87"N)
Upper Right ( 6363148.438, 9275122.969) (102d28'44.29"W, 68d16'20.89"N)
Lower Right ( 6363148.438, -735684.662) (129d33' 9.18"W, 44d39'10.85"N)
Center      (   65100.882, 4269719.153) (153d37'25.66"W, 61d41'25.08"N)
Band 1 Block=1754x4 Type=Byte, ColorInterp=Gray
  Min=52.000 Max=251.000 
  Minimum=52.000, Maximum=251.000, Mean=203.398, StdDev=16.720
  NoData Value=0
  Metadata:
    STATISTICS_MAXIMUM=251
    STATISTICS_MEAN=203.39817191777
    STATISTICS_MINIMUM=52
    STATISTICS_STDDEV=16.720180362479

#7 Updated by Giovanni Manghi over 1 year ago

Jorge Rocha wrote:

Not happens on Ubuntu 3.4.4-Madeira.

Is the image ok? maybe corrupted? Can you run gdalinfo on it?

yes, no and no.

It happens with ALL tif files, only on Windows.

#8 Updated by Jürgen Fischer over 1 year ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

Also available in: Atom PDF