Bug report #21224

Changing feature values in the Attribute Table of a layer (geojson) doesn't save (after clicking save button), old values appear after reloading

Added by Haitham Shatti 9 months ago. Updated 9 months ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Vectors
Affected QGIS version:3.4.4 Regression?:No
Operating System:Windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:29042

Description

I have few Layers in geojson format and i'm trying to change some attributes in the attribute table (a QString column), the table shows the new changes and i click save and un-toggle the "edit" button with all the new updates in place, now closing and opening the layer again shows the old values as if no change were saved, i tried to close and open the project again and still the old values are there, i think this could be a burning area to fix in the next versions.

berlin.geojson (136 KB) yoichi Kayama, 2019-03-01 08:23 AM

screenshot2019-03-01 16.22.11.png (27.4 KB) yoichi Kayama, 2019-03-01 08:25 AM

screenshot2019-03-01 16.22.41.png (27.3 KB) yoichi Kayama, 2019-03-01 08:25 AM

History

#1 Updated by Giovanni Manghi 9 months ago

  • Crashes QGIS or corrupts data changed from Yes to No
  • Category changed from Attribute table to Vectors
  • Status changed from Open to Feedback
  • Priority changed from High to Normal

Please attach sample data.

#2 Updated by yoichi Kayama 9 months ago

The same problem occurred in my environment. I edited the attribute data of GeoJson file with a table, but the editing result was not saved. I edited berlin.geojson in the example.The editing result was written in a file berlin.geojson.tmp, but berlin.geojson has not been updated.

#3 Updated by Giovanni Manghi 9 months ago

duplicate of #21310 ?

#4 Updated by Giovanni Manghi 9 months ago

  • Subject changed from Changing feature values in the Attribute Table of a layer (geojason) doesn't save (after clicking save button), old values appear after reloading to Changing feature values in the Attribute Table of a layer (geojson) doesn't save (after clicking save button), old values appear after reloading

#5 Updated by yoichi Kayama 9 months ago

I think it is duplicate #20760

#6 Updated by Giovanni Manghi 9 months ago

  • Status changed from Feedback to Closed
  • Resolution set to duplicate

yoichi Kayama wrote:

I think it is duplicate #20760

yes sorry, I meant that one.

Also available in: Atom PDF