Bug report #2122

trunk compilation errors

Added by Markus Neteler almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Build/Install
Affected QGIS version: Regression?:No
Operating System:Mandriva Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:12182

Description

I don't manage to compile trunk on Mandriva 2008, 64bit:

...
-- Found Qt-Version 4.3.1                                                                                                                                                             
-- Found Qt-Version 4.3.1                                                                                                                                                             
-- Configuring done                                                                                                                                                                   
-- Generating done                                                                                                                                                                    
-- Build files have been written to: /home/neteler/software/qgis_trunk/build                                                                                                          
[  0%] [  1%] [  1%] Built target svnversion                                                                                                                                          
Built target pluginstaller                                                                                                                                                            
Built target mapserverexport                                                                                                                                                          
[  8%] [  8%] Built target ...                                                                                               
[ 33%] Building CXX object src/gui/CMakeFiles/qgis_gui.dir/qgsdetaileditemdelegate.o                                                                                                  
[ 33%] Building CXX object src/providers/wfs/CMakeFiles/wfsprovider.dir/qgswfsprovider.o
[ 33%] Building CXX object src/providers/grass/CMakeFiles/qgisgrass.dir/qgsgrassprovider.o
/home/neteler/software/qgis_trunk/src/gui/qgscolorbutton.cpp: In member function ‘void [[QgsColorButtonV]]2::setColor(const QColor&)’:
/home/neteler/software/qgis_trunk/src/gui/qgscolorbutton.cpp:93: error: ‘class QPainter’ has no member named ‘drawRoundedRect’
maker2: *** [src/gui/CMakeFiles/qgis_gui.dir/qgscolorbutton.o] Error 1
maker2: *** Waiting for unfinished jobs....
[ 33%] Building CXX object src/providers/wfs/CMakeFiles/wfsprovider.dir/qgswfsdata.o
maker1: *** [src/gui/CMakeFiles/qgis_gui.dir/all] Error 2
maker1: *** Waiting for unfinished jobs....
[ 33%] Building CXX object src/providers/grass/CMakeFiles/qgisgrass.dir/qgsgrass.o
[ 33%] Building CXX object src/providers/wfs/CMakeFiles/wfsprovider.dir/moc_qgswfsdata.o
[ 33%] Building CXX object src/providers/wfs/CMakeFiles/wfsprovider.dir/moc_qgswfsprovider.o
Linking CXX shared library libqgisgrass.so
Linking CXX shared module libwfsprovider.so
[ 33%] Built target qgisgrass
[ 33%] Built target wfsprovider
make: *** [all] Error 2
[  0%] Built target svnversion
[  7%] Built target ui
[ 23%] Built target qgis_core
[ 23%] Building CXX object src/gui/CMakeFiles/qgis_gui.dir/qgscolorbutton.o
/home/neteler/software/qgis_trunk/src/gui/qgscolorbutton.cpp: In member function ‘void [[QgsColorButtonV]]2::setColor(const QColor&)’:
/home/neteler/software/qgis_trunk/src/gui/qgscolorbutton.cpp:93: error: ‘class QPainter’ has no member named ‘drawRoundedRect’
maker2: *** [src/gui/CMakeFiles/qgis_gui.dir/qgscolorbutton.o] Error 1
maker1: *** [src/gui/CMakeFiles/qgis_gui.dir/all] Error 2
make: *** [all] Error 2

Deleting the offending line (brutal hack) leads to the next error:

[ 51%] Building CXX object src/app/CMakeFiles/qgis.dir/qgsaddattrdialog.o
/home/neteler/software/qgis_trunk/src/app/qgisapp.cpp: In member function ‘void [[QgisApp]]::loadPythonSupport()’:
/home/neteler/software/qgis_trunk/src/app/qgisapp.cpp:4882: error: no matching function for call to ‘QLibrary::QLibrary(QString&, QString&)’
/usr/lib/qt4/include/QtCore/qlibrary.h:96: note: candidates are: QLibrary::QLibrary(const QLibrary&)
/usr/lib/qt4/include/QtCore/qlibrary.h:68: note:                 QLibrary::QLibrary(const QString&, int, QObject*)
/usr/lib/qt4/include/QtCore/qlibrary.h:67: note:                 QLibrary::QLibrary(const QString&, QObject*)
/usr/lib/qt4/include/QtCore/qlibrary.h:66: note:                 QLibrary::QLibrary(QObject*)
[ 51%] Building CXX object src/app/CMakeFiles/qgis.dir/qgsattributeactiondialog.o
maker2: *** [src/app/CMakeFiles/qgis.dir/qgisapp.o] Error 1
maker2: *** Waiting for unfinished jobs....
Parsing SIP files for 'gui' library...
/usr/bin/sip -c gui -b /home/neteler/software/qgis_trunk/build/python/gui/gui.sbf -I /home/neteler/software/qgis_trunk/python -I /usr/share/sip/PyQt4 -x [[VendorID]] -t WS_X11 -x [[PyQt]]_NoPrintRangeBug -t Qt_4_3_0 -g /home/neteler/software/qgis_trunk/python/gui/gui.sip
maker1: *** [src/app/CMakeFiles/qgis.dir/all] Error 2
Parsing SIP files for 'analysis' library...
/usr/bin/sip -c analysis -b /home/neteler/software/qgis_trunk/build/python/analysis/analysis.sbf -I /home/neteler/software/qgis_trunk/python -I /usr/share/sip/PyQt4 -x [[VendorID]] -t WS_X11 -x [[PyQt]]_NoPrintRangeBug -t Qt_4_3_0 -g /home/neteler/software/qgis_trunk/python/analysis/analysis.sip
Creating makefiles...
Creating qgisconfig.py...
...

History

#1 Updated by Markus Neteler almost 10 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

sorry, created due to unresponsive trac. Clone of #2122

Also available in: Atom PDF