Bug report #21163

Empty or corrupt file when exporting to Mapinfo TAB with EPSG 4647

Added by Slava Ermolaev 12 months ago. Updated 11 months ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Projection Support
Affected QGIS version:3.4.4 Regression?:No
Operating System:Windows 10 64-Bit, Ubuntu 18.04 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:28981

Description

The created file is broken by exporting as Mapinfo TAB with the projection EPSG 4647. The same export to EPSG 25832 works properly.

Steps to reproduce:
  • Open the GeoPackage savetotab4647.gpkg in QGIS
  • Select Export > Save Features As:
  • Select MapInfo Tab as Format
  • EPSG: 4647 - ETRS89 / UTM zone 32N (zE-N) as CRS
  • File name and location - whatever
  • Save with OK
  • Inspect the produced Mapinfo TAB file with "Zoom to Layer": no geometry at all (windows) or just the vertical lines (Linux) in the wrong position.

Try the same steps with EPSG 25832 as output projection. And finally with EPSG 4647 but export it to the Mapinfo MIF. Both works as expected.

savetotab4647.gpkg (104 KB) Slava Ermolaev, 2019-02-04 04:34 PM

History

#1 Updated by Slava Ermolaev 11 months ago

  • Status changed from Open to Closed

The problem was caused by a bug in the GDAL library. See issue here: https://github.com/OSGeo/gdal/issues/1316

Also available in: Atom PDF