Bug report #21139

Updating parent symbol results in undefined fill color at child symbols

Added by Simon Gröchenig 12 months ago. Updated 12 months ago.

Status:Open
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:3.4.4 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:28957

Description

I observe a bug in the categorized symbology. I prepare a parent symbol and create the child symbols afterwards. If I have to modify the parent symbol afterwards (e.g. line width), the fill color of all child symbols resets to black (attachment 'qgis_parent_symbol_bug.png') or maybe undefined (attachment 'qgis_empty_color.png').

It sometime works as expected in the first parent update, but it fails in the second one.

Expected behavior: Child symbol fill color should not change after updating the parent.

qgis_parent_symbol_bug.png (32.7 KB) Simon Gröchenig, 2019-01-31 08:32 AM

qgis_empty_color.PNG (7.23 KB) Simon Gröchenig, 2019-01-31 08:37 AM

History

#1 Updated by Giovanni Manghi 12 months ago

  • Priority changed from High to Normal
  • Status changed from Open to Feedback

Did it worked as expdcted in 2.18 or a previous 3.x release?

#2 Updated by Simon Gröchenig 12 months ago

I can reproduce the issue also in QGIS 2.18.28.

#3 Updated by Simon Gröchenig 12 months ago

An important comment: I tried to reproduce the issue in a new project. I discovered that it occurs only if one (or more) geometry generators are used (and no other symbol types)

#4 Updated by Giovanni Manghi 12 months ago

  • Status changed from Feedback to Open

Also available in: Atom PDF