Bug report #21114

Grass algorithms doesn't work from Processing Toolbox level (grass-7.7.svn folder problem)

Added by Marcin Domański about 1 year ago. Updated about 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/GRASS
Affected QGIS version:3.4.4 Regression?:No
Operating System:Windows 10 Easy fix?:Yes
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:28932

Description

Each time I want to run one of Grass algorithms, I get this kind of error:
ValueError: invalid literal for int() with base 10: 'svn'

This is because folder has strange name (after OS4GEO installation):
grass-7.7.svn

When I remove ".svn" from name (only grass-7.7) everything is ok.

Below detailed discussion in one of forums, there was proposal to raise ticket on it, but probably original poster was satisfied with this workaround and there is still no ticket for that.
http://osgeo-org.1560.x6.nabble.com/QGIS-3-4-2-GRASS-td5388525.html

Associated revisions

Revision febbc4f0
Added by Jürgen Fischer about 1 year ago

osgeo4w: handle grass svn versions (fixes #21114)

Revision 3221b1c8
Added by Jürgen Fischer about 1 year ago

osgeo4w: handle grass svn versions (fixes #21114)

(cherry picked from commit febbc4f0b9e6f1e1c74c18bcb117148d6587ff87)

History

#1 Updated by Jürgen Fischer about 1 year ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF