Bug report #21099

Postgis DB selector for outputs fails to list schemas in selected DB

Added by Victor Olaya about 1 year ago. Updated about 1 year ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/GUI
Affected QGIS version:3.5(master) Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:28917

Description

The defined connection appear in the selector window, but the tree is empty, with no schemas under each DB

Associated revisions

Revision 1b4a9132
Added by Victor Olaya about 1 year ago

[processing] avoid exception when listing DB schemas

do not fail if cert file cannot be deleted when creating GeoDB object

fixes #21099

Revision 11435027
Added by Victor Olaya about 1 year ago

[processing] avoid exception when listing DB schemas

do not fail if cert file cannot be deleted when creating GeoDB object

fixes #21099

(cherry picked from commit 1b4a9132c2bceb348bbb56177da75094dbb4cb5e)

History

#1 Updated by Victor Olaya about 1 year ago

Looks like all parts of Processing where a schema list has to be shown, an exception is raised when in windows

#2 Updated by Victor Olaya about 1 year ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF