Bug report #2109

Quick Print plugin crashes qgis when used with symbolog-ng vectors

Added by cgsbob - almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:Martin Dobias
Category:Python plugins
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:12169

Description

Steps to reproduce crash:
1) Load vector and change its symbology using the Labeling plugin.
2) Create PDF by using Quick Print plugin
3) Refresh screen (pan, zoom, or refresh)
4) Crash with the following message (same message as #2108):

Warning: Qt has caught an exception thrown from an event handler. Throwing
exceptions from an event handler is not supported in Qt. You must
reimplement QApplication::notify() and catch all exceptions there.

terminate called after throwing an instance of 'pal::PalException::LayerExists*'
Aborted

History

#1 Updated by Martin Dobias almost 10 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #2108

Also available in: Atom PDF